Forum Announcement

Collapse
No announcement yet.

1999 EzGO Speed Controller Question

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1999 EzGO Speed Controller Question

    I have a 1999 EzGo that takes off fine then as you push the pedal it starts to slow down and sometimes stops. I then push about half way and it runs fine but as I move the pedal forward it starts to slow down. I can hear the solenoid click each time I move the pedal so I am pretty sure the solenoid is fine. I am assuming the speed controller is going bad but is it possible it could be a motor issue and the speed controller is shutting it down to prevent damage? or could it be a thermal issue? I am looking for opinions before I invest in a controller $$$ Thanks in advance for advice.

    Update: I ran a few more tests today: I made sure the batteries were fully charged. The cart takes off fine and it runs for about 60 feet then it loses power, does not sound like the solenoid kicks out. I back out of the pedal and wait for the solenoid to click then I tip back in and the solenoid clicks and the cart takes off again. I do this 2-3 times then the cart never gets back to the original speed and eventually it goes into a slow limp mode. I checked the main motor wires and the motor housing for overheating (it was cool). I load tested each of the batteries and when I hook them up they show good but when I initiate the load test they move toward the weak range. I checked the voltage between the B- and the M- on the speed control module and it was at Battery voltage (36V). I then pushed the accelerator pedal and monitored the voltage at B- and M-, the more I pushed the lower the voltage dropped. I am wondering if there is a way to test the speed controller (Curtis PMC 73263 G01)? Does this sound like it could be a speed controller issue? Or something else? Any other trouble shooting ideas would be greatly appreciated.
    Last edited by mmcconn2; February 28, 2018, 06:19 PM.

  • #2
    I would check your throttle sensor. Before you check the ecpensive parts cross your fingers and make sure your throttle sensor is good and adjusted correctly
    Last edited by Coastalcarolinacarts; March 21, 2018, 08:53 PM.

    Comment

    Unconfigured Ad Widget

    Collapse
    Loading
    X